Back to overview
Resolved

All hosted sites returning 404

Aug 27, 2026 at 10:38am UTC
Affected services
Notion sync
Domains

Resolved
Aug 27, 2026 at 10:38am UTC

We've noticed an issue affecting sites hosted on Super and are actively working on a resolution.