Back to overview
Downtime

Pages ends up with 404

Jun 23, 2026 at 9:51am UTC
Affected services
Domains

Resolved
Jun 23, 2026 at 10:09am UTC

Our engineering team found the root cause, all sites should be back up.

Created
Jun 23, 2026 at 9:51am UTC

Users getting page not found 404 error on their sites. Engineering team is currently investigating the root cause.